The Joomla! Community Portal ™

Wed

05

Aug

2009

Testing Help with PHP 5.3.0
Written by Mark Dexter   
Wednesday, 05 August 2009 00:12

As many of you know, PHP version 5.3.0 was released a few weeks ago and is now being deployed on some server sites. Not surprisingly, there are a few issues running Joomla! with this new PHP version. The Bug Squad would like to be able to support PHP 5.3.0 in our next maintenance release (version 1.5.15).

We have a proposed set of fixes that we believe solves all of the known 5.3.0 issues, and we are asking people in the community to help us test this. To make it as easy as possible to test, we have created a test download of Joomla! that includes the proposed patch.

IMPORTANT NOTE: This download is only for testing should NOT be used in any type of production environment. It should only be used to test that it fixes any issues with PHP 5.3.0 and doesn't create any problems for earlier PHP versions.

The download is available in the tracker here: http://joomlacode.org/gf/download/trackeritem/17150/42624/joomla_php53test.zip. You can install this just like you do a production version of Joomla.

If you are able to test it, please leave a comment in the tracker (http://joomlacode.org/gf/project/joomla/tracker/?action=TrackerItemEdit&tracker_item_id=17150) or add a comment below.

Thanks very much for your help.