The Joomla! Community Portal ™

Wed

06

Feb

2013

JED 1.5 Version Support Ends
Written by Matthew Baylor   
Wednesday, 06 February 2013 20:03

As planned back in April 2012, the JED will begin the transition of dropping support for Joomla 1.5 only extensions.

The 1.5 timeline

  • April 1, 2012: we no longer accepted 1.5 only submissions.
  • February 15, 2013: the 1.5 compatibility icon will be disabled for new submissions.
  • March 1, 2013: We will begin unpublishing listings that are marked as Joomla 1.5 only and remove the 1.5 icons. After a 1.5 only listing is unpublished developers will have 14 days to update the unpublished listing with a 2.5 and/or 3.0 version. Once updated a support ticket will need to be opened to get the listing republished.
  • March 15, 2013: all non-compatible listings will be purged from the system. Once a listing is purged, to get the extension listed again, it will need to be submitted as new.

Some current numbers

  • 4,425 listings are marked as Joomla 1.5 only
  • 6,518 listings are marked as Joomla 2.5 compatible
  • 1,994 listings are marked as Joomla 3.0 compatible

Where can I find 1.5 extensions after March?

There have been some requests of creating a repository for 1.5 listings. With our current workload and projects on the horizon we do not have the manpower to create a repository at this time.

We will pull an archive of the site prior to removing any 1.5 listings and make it available for anyone who would like to put a repository together.

Once our 3.0 migration project is complete we will revisit the possibility of creating a 1.5 listing repository.

A repository/acrhive has been created and is available at http://archive.extensions.joomla.org

You can comment on this blog post here.